Kurs:OpenOffice.org/Kalkulationen

Aus Wikiversity
Zur Navigation springen Zur Suche springen
Programmsymbol von Openoffice Calc

Für das Gebiet der Tabellenkalkulation bietet Openoffice das als „Calc“ bezeichnete Programm. Hinweise zur Bezugsquelle sind im allgemeinen Teil zu finden.

Dieser Kursabschnitt widmet sich den allgemeinen Handhabungen und gibt einen Kurzeinstieg in die Nutzung des Programms anhand der Version 2.3.1


Arbeitsmappe[Bearbeiten]

Hilfemenü zur Info-Auswahl
Informationen zur Programmversion

Eine Calc-Datei stellt, wie eine Mappe, eine Hülle um die verwendeten Tabellen dar. Wer regelmäßig seine Software aktualisiert sollte sich vergewissern, mit welcher Version er eigentlich gerade arbeitet. Dazu kann das „Hilfe“-Menü aufgeklappt und dort dann das Untermenü „Info über OpenOffice.org“ ausgewählt werden.

Standardtabellenregister

Die vorhandenen Tabellenblätter lassen sich im unteren Randbereich an den Tabellenregistern erkennen.

Kontextmenü der Tabellenregister
Navigationselemente für Tabellenregister

Durch Klick mit der rechten Maustaste auf eines dieser Register kann im aufklappenden Kontextmenü jederzeit eine Tabelle eingefügt, vorhandene Tabellenblätter umbenannt, gelöscht oder auch kopiert oder verschoben werden. Falls sehr viele Tabellenblätter angelegt wurden, kann es passieren, dass die Register dieser Tabellen zu viel Platz beanspruchen und nicht vollständig zu sehen sind. In diesem Fall helfen die Navigationselemente am unteren Randbereich links neben den Registern. Mit ihrer Hilfe kann tabellenweise das Register nach links, rechts oder auch zum Beginn oder Ende der Register verschoben werden.


Aufgabe:
Die Tabellen sollen folgende Registerbezeichnungen erhalten:
benannte Tabellenregister
  • Einkaufsliste
  • Termine
  • Termine Mutter
  • Termine Vater
  • Kalender

Nachdem bereits einige Tabellen benannt wurden, sollten die veränderten Daten gespeichert werden.

„Datei“-Menü zum Speichern der Datei

Vorerst hat die neue Calc-Datei noch den Namen „Unbenannt1“. Nach dem Speichern der Daten sollte die Datei allerdings eine andere, aussagekräftigere Bezeichnung haben. Das Speichern kann auf vielerlei Weise geschehen:

  • durch Mausklick auf das Menü „Datei“ und Auswahl des Untermenüs „Speichern“
  • durch die Tastenkombination Strg+S
  • durch Mausklick auf das Diskettensymbol in der Standardsymbolleiste unterhalb der Menüleiste von Openoffice.

Aufgabe:
Die gesamte Datei soll gespeichert werden, wobei der Dateiname „Tag1“ zugewiesen werden soll.

Nachdem die Daten gespeichert sind, kann das Calc-Programm beendet werden. Auch hier gibt es wieder mehrere Möglichkeiten:

  • durch Mausklick auf das Menü „Datei“ und Auswahl des Untermenüs „Beenden“
  • durch die Tastenkombination Strg+Q
  • durch die Tastenkombination Strg+F4


Tabellenblatt[Bearbeiten]

Kontextmenü zur Zellbearbeitung

Das einzelne Tabellenblatt enthält die in Spalten und Zeilen angeordneten Zellen.

Die Spalten tragen Buchstaben als Kennung, während die Zeilen nummeriert sind. Die aktuell markierte Zelle erkennt man an der stärkeren Umrahmung, deren Name sich aus Spaltenbuchstabe gefolgt von Zeilennummer zusammensetzt. In der Abbildung enthält die Zelle „A5“ den Inhalt „Eier“.

Namensfeld zur Zellbezeichnung

Die Zellen werden optisch durch ein Gitternetz voneinander getrennt. Die Eingabe in die Zellen geschieht durch einfaches Schreiben. Nachdem die Inhalte in die Zellen eingefügt wurden, kann auch nachträglich jeder Zellinhalt nochmals editiert werden. Durch Klick mit der rechten Maustaste auf eine ausgefüllte Zelle, öffnet sich das zugehörige Kontextmenü, aus welchem das weitere Vorgehen gewählt werden kann.

Das Navigieren durch die Zellen geschieht entweder mittels Cursor-Tasten oder durch Mausklick. Als Schnellvariante bietet sich das Namensfeld in der Bearbeitenleiste an: Durch Eingabe des Zellnamens springt die Zellmarkierung sofort zur entsprechenden Zelle.


Symbolleisten[Bearbeiten]

Kopfbereich des Arbeitsfensters
frei positionierte Standardsymbolleiste
Auswahlliste der Symbolleisten

Bestandteil der Arbeitsumgebung des Kalkulationsprogramms sind diverse Leisten, die sich in der Regel am oberen Fensterrand ansammeln.

  • Die „Titelleiste“ des Fensters gibt Auskunft über die Bezeichung der gerade laufenden Anwendung und den Namen des geöffneten Dokuments.
  • Die unterhalb der Titelleiste befindliche „Menüleiste“ gestattet die Auswahl verschiedener Aktionen aus einer gegliederten Ansammlung von Menüeinträgen.
  • Direkt unterhalb der Menüleiste sind im Standardfall zwei weitere Leisten mit grafischen Abbildungen – die Symbolleisten – zu finden:
    • die Symbolleiste mit den Standardsymbolen - „Standardsymbolleiste“
    • die Symbolleiste mit den Symbolen zur Formatierung - „Formatsymbolleiste“

Diese und weitere Symbolleisten können über das Menü „Ansicht“ aus dem Untermenü „Symbolleisten“ aktiviert oder deaktiviert werden. Darüberhinaus befindet sich am linken Rand einer jeden Symbolleiste eine senkrechte hervorgehobene Markierung, mit deren Hilfe und mit Hilfe der Maus sich diese Leiste verschieben lässt.

frei positionierte Formatsymbolleiste

Hat man erst mal eine Symbolleiste vom Fensterrand ins Fensterinnere verschoben, stellt diese Leiste ein eigenständiges Fenster dar, deren Breite und Höhe sich verändern lässt. Nach einem Klick mit der rechten Maustaste auf die „Schließen“-Schaltfläche der Symbolleiste - sie befindet sich in der oberen rechten Fensterecke - verschwindet die Symbolleiste von der Bildfläche. Sie kann aber über das „Ansicht“-Menü als Symbolleiste wieder aktiviert werden.

Dialogfenster zum Anpassen der Symbolleisten

Wenn eine im Fensterinneren dargestellte Symbolleiste wieder an den Fensterrand befördert werden soll, bietet sich ein Doppelklick (mit der linken Maustaste) in die Titelleiste der Symbolleiste an. Die Symbolleiste springt dann an denjenigen Fensterrand, wo sie zuletzt mal positioniert war.

Fortgeschrittene und Individualisten haben die Möglichkeit, sich den Inhalt einer Symbolleiste anzupassen - also die Sammlung grafischer Symbole zu beeinflussen. Dies geschieht über das Menü „Extras“ und das Untermenü „Anpassen“.

Wer sich seine Neugier bewahrt hat, wird bei dieser Gelegenheit herausfinden, dass das Anpassen nicht nur auf Symbolleisten beschränkt ist.

Wenn im Laufe der Arbeiten Nachhilfe nötig wird, bietet sich zuerst mal die programmeigene Hilfe über das „Hilfe“-Menü an.


Zwischenstopp[Bearbeiten]

Quiz
zum Quiz01

Zur Besinnung auf die bisher verwendeten Begriffe empfiehlt sich ein Quiz.

Zellen[Bearbeiten]

An den Schnittstellen von Zeilen und Spalten befinden sich die Zellen des Tabellenblattes. Der Name einer Zelle wird im Standardfall aus dem Spaltenbuchstaben und der Zeilennummer gebildet.

Aufgabe:
Vergewissere Dich, wie weit die Buchstaben der Spaltennamen vorhanden sind. Navigiere hierzu durch das Tabellenblatt, bis Du den rechten Tabellenrand erreicht hast.

Das Navigieren durch die Zellen des Tabellenlattes geschieht mittels Cursortasten oder auch Tastenkombinationen, etwa:

  • Strg+->, Sprung nach rechts
  • Strg+<-, Sprung nach links

Weitere Tastenkombinationen, etwa zum hoch- oder runternavigieren lassen sich analog finden.

Aufgabe:
Vergewissere Dich, wieviele Zeilen vorhanden sind. Navigiere hierzu durch das Tabellenblatt, bis Du den unteren Tabellenrand erreicht hast.

In einer kleinen Tabelle soll die Gesamtanzahl von Zellen ermittelt werden:

  • Spalten von A-Z, AA-AZ, BA-BZ, CA-CZ, ..., IA-IV: somit haben wir 10 * 26 Spalten abzüglich 4 fehlender Spalten, nämlich IW-IZ.
  • Zeilen existieren in der Openoffice-Version 2.3.1 insgesamt 65536 pro Tabellenblatt.

Um Informationen in die Zellen zu schreiben, genügt es, die gewünschte Zelle zu markieren – sie ist dann mit einem hervorgehobenen Rahmen versehen – und loszuschreiben. Die Überschrift soll in die Zelle A1, die sonstigen Beschriftungen in A2 bis A4. Gewöhnlicher Text wird nach der Eingabe linksbündig ausgerichtet. Davon abweichende Formatierungswünsche lassen sich natürlich verwirklichen, unter anderem mit Hilfe der Schaltflächen der Formatsymbolleiste.

Ermittlung der Zellenanzahl

Die Angaben zur Gesamtzahl Spalten soll in die Zelle B2, allerdings soll Openoffice uns beim Ermitteln der korrekten Anzahl behilflich sein: daher schreibt man eine „Berechnungsanforderung“ (man könnte es auch weniger bombastisch als Formel bezeichnen). Eine solche Formel beginnt mit der Eingabe eines Gleichheitszeichens und wird gefolgt von der Berechnunsgvorschrift: 10*26-4. Nach der Eingabe die Enter-Taste betätigen, damit Openoffice mitbekommt, dass wir in diese Zelle nichts mehr eintragen wollen.

Die Gesamtzahl der Spalten ist einfach nur eine Zahl, nämlich 65536.

Ermittlung der Zellenanzahl, Formelansicht

Interessanter wird es bei der Ermittlung der Gesamtanzahl, welche in der Zelle B4 erfolgen soll: Hier soll ja ebenfalls durch unser Tabellenkalkulationsprogramm die Berechnung aus den Werten in der Zelle B2 und B3 durchgeführt werden. Also schreiben wir auch hier die Berechnungsanforderung - also, die Formel hin: =B2*B3 und schließen auch diese Eingabe mit der Enter-Taste ab. Das war's schon.

Ansichtsoptionen von Openoffice Calc

In der Normalansicht sieht man die Ergebnisse der Berechnungen. Über die Menüabfolge „Extras“ - „Optionen“ gelangt man zu den „Ansichts“-Optionen von Openoffice-Calc. Durch Aktivieren der Formeln wechselt die Ergebnisansicht zur Formelansicht. Hier können die Formeln in ihrer gesamten Schönheit bewundert werden. Nach Deaktivierung dieser Ansichtsfunktion werden wieder die Berechnungsergebnisse angezeigt.

Namensvergabe für eine Zelle

Leider sind die Formeln nicht für sich selbst sprechend. Dies lässt sich aber verbessern, indem den verwendeten Zellen frei vergebbare Namen zugewiesen werden. Dies geschieht durch Markieren der zu benennenden Zelle und anschließendes Schreiben des gewünschten Namens ins Namens- bzw. Bereichsfeld. Nach Abschluss dieser Zellbenennungen kann die Formel unter Verwendung der neuen Zellnamen umgeschrieben werden.

Dialogfenster „Namen festlegen“

Falls bei diesen Benennungen Fehler unterlaufen, oder der ein oder andere Name im Nachhinein verändert werden soll, gibt es die Menüabfolge „Einfügen“ - „Namen“ - „Festlegen“ (bzw. die Tastenkombination Strg+F3. Im sich öffnenden Dialogfenster kann die Übersicht bisher angelegter benannter Zellbereiche editiert werden.

Benannte Zellen in einer Formel

In der Formelansicht kann man sich von der nunmehr leichter verständlichen Rechenvorschrift (in Zelle B4) überzeugen. Das Rechenergebnis hat sich durch die Umbenennungen natürlich nicht verändert, wie man in der Ergebnisansicht sehen kann.

Aufgabe:
Erstelle eine tabellarische Einkaufsliste, welche in der ersten Spalte verschiedene Einkaufsartikel enthält und in der zweiten Spalte deren Preise pro Verkaufseinheit. Als Verkaufseinheit kommen zum Beispiel Packung, Liter, Stück, Gramm, Kilogramm und sonstige Mengenbezeichnungen in Frage.

Die folgenden Spalten sollen die Wochentage Montag bis Freitag repräsentieren.

Unterhalb der Tabelle soll sich eine Zeile befinden, die pro Wochentag den Preis für den gesamten Tageseinkauf darstellt.

Die Abbildung einer möglichen Lösung findest Du hier.


Zellbezüge[Bearbeiten]

Wenn in einzelne Zellen der Kalkulationstabelle Rechenvorschriften - im Weiteren als Formeln bezeichnet - geschrieben werden, so können diese Formeln sowohl Zahlen als auch Bezugnahmen auf andere Zellen enthalten. Diese Bezugnahmen entstehen durch das Verwenden der Zellnamen innerhalb der Formeln.

Zum Beispiel verwendet die Formel:

=B23+2*C23

den Inhalt der Zelle „B23“ und addiert das Doppelte des Inhalts der Zelle „C23“ hinzu um nun das Ergebnis in der aktuellen Zelle zu repräsentieren. Diese Bezugnahmen auf andere Zellinhalte kann man in jeder Zelle aufs neue Schreiben. Ab und zu ergeben sich jedoch gleichartige Formeln der Art:

nimm den Inhalt der linken Zelle und multipliziere ihn mit dem Inhalt der Zelle A11

und dies womöglich über mehrere Zeilen oder Spalten hinweg. Es wäre mühselig, diese Formeln immer wiederschreiben zu müssen. Dafür gibt es die Möglichkeit des „Übertragens“ der aktuellen Formel in die Zellen der benachbarten Zeilen oder Spalten.

Dies geschieht durch Markieren der gewünschten Zelle und Ziehen am kleinen schwarzen Markierungsquadrat unten rechts am Markierungsrahmen.

relative und absolute Zellbezüge (Formelansicht)

Die nebenstehende Abbildung stellt dar, was mit den Zellnamen beim Übertragen geschieht:

Ausgehend von der in der Mitte stehenden Zelle wurde die Formel: =D10+E$11*$F12+$G$13 sowohl in senkrechter, als auch in waagerechter Richtung auf die Nachbarzellen übertragen.

Wichtig ist hier, zu beachten, was mit den einzelnen Zellnamen geschieht:

Zellname Übertragungsrichtung
senkrecht waagerecht
nach oben nach unten nach links nach rechts
D10 D9 bzw. D8 D11 bzw. D12 C10 bzw. B10 E10 bzw. F10
E$11 E$11 E$11 D$11 bzw. C$11 F$11 bzw. G$11
$F12 $F11 bzw. $F10 $F13 bzw. $F14 $F11 $F11
$G$13 $G$13 $G$13 $G$13 $G$13

  • Ein Zellbezug, der im Zellnamen nur Spaltenbuchstabe gefolgt von der Zeilennummer enthält, wird beim senkrechten Übertragen bezüglich seiner Zeilennummer verändert und beim waagerechten Übertragen bezüglich seines Spaltenbuchstabens, wodurch sich die Formel auf den Inhalt der jeweils angesprochenen Zelle bezieht.
„Ein solcher Zellbezug wird als ‚relativ‘ bezeichnet“
  • Ein Zellbezug, der im Zellnamen vor dem Spaltenbuchstaben kein Dollarsymbol („$“), dafür aber ein solches Symbol vor der Zeilennummer trägt, wird beim senkrechten Übertragen bezüglich seiner Zeilennummer unverändert gelassen, während er beim waagerechten Übertragen bezüglich seines Spaltenbuchstabens aktualisiert wird. Hierdurch ändert sich der Zellbezug also nur beim Übertragen in waagerechter Richtung.
„Ein solcher Zellbezug wird als ‚relativ‘ bezüglich der Spaltenbezeichnung und als ‚absolut‘ bezüglich der Zeilennummer bezeichnet“

  • Ein Zellbezug, der im Zellnamen vor dem Spaltenbuchstaben ein Dollarsymbol („$“) trägt, aber kein solches Symbol vor der Zeilennummer, wird beim senkrechten Übertragen bezüglich seiner Zeilennummer verändert, aber beim waagerechten Übertragen bezüglich seines Spaltenbuchstabens unverändert gelassen. Hierdurch ändert sich der Zellbezug also nur beim Übertragen in senkrechter Richtung.
„Ein solcher Zellbezug wird als ‚absolut‘ bezüglich der Spaltenbezeichnung und als ‚relativ‘ bezüglich der Zeilennummer bezeichnet“
  • Ein Zellbezug, der im Zellnamen sowohl vor dem Spaltenbuchstaben als auch vor der Zeilennummer ein Dollarsymbol („$“) trägt, wird sowohl beim senkrechten als auch beim waagerechten Übertragen bezüglich seines Namens unverändert gelassen. Hierdurch ändert sich der Zellbezug also überhaupt nicht.
„Ein solcher Zellbezug wird als ‚absolut‘ bezeichnet“

Das Dollarsymbol kann bei der Formeleingabe mitgeschrieben werden. Es kann aber auch mit Hilfe der +F4-Tastenkombination ("Umschalttaste" + "F4"-Taste) erzeugt werden, wenn der Zellname geschrieben wurde und der Cursor direkt hinter den Zellnamen steht. Ein wiederholtes Betätigen der +F4-Tastenkombination stellt die verschiedenen relativen oder absoluten Varianten her.

Benannte Zellen sind immer absolut bezüglich Spalte und Zeile

Formeln[Bearbeiten]

werden zur Berechnung von Ergebnissen verwendet

    • Zellbezüge
    • Werte

gemeinsame Übungen[Bearbeiten]

  • Einkaufsartikel als benutzerdefinierte Liste anlegen
  • Zellformatierung als Währung
  • benutzerdefinierte Zellformatierungen mit Maßeinheiten
  • Preisberechnung aus Anzahl mal Einzelpreis
  • Summenbildung
  • Format übertragen

selbständige Übung[Bearbeiten]

  • Wocheneinkaufsliste erstellen
    • 5 Wochentage
    • Einkaufsartikel
    • tägliche Anzahl incl. Formatierung

Ergänzungen[Bearbeiten]

  • Rahmen
  • Hintergrund
  • Gitter ein-/ausblenden
  • Schattierung

für Fortgeschrittene[Bearbeiten]

  • zusätzliche Preisspalte
  • Gesamtzeile pro Wochentag
  • Summenprodukt pro Wochentag
    • absolute und relative Zellbezüge
  • Hilfe

Übungsaufgaben[Bearbeiten]

Tankverbrauch[Bearbeiten]

Der PKW-Fahrer Paul Panke führte Buch über seine letzten getankten Liter Benzin

1. 45 l zu 1,299
2. 30 l zu 1,369
3. 40 l zu 1,339
4. 45 l zu 1,359
5. 42 l zu 1,369
6. 40 l zu 1,299
7. 35 l zu 1,349
8. 40 l zu 1,289

Wieviele Liter hat Paul Panke insgesamt getankt?
Was hat der einzelne Tankvorgang gekostet?
Wieviel hat Paul insgesamt für die Tankfüllungen bezahlt?
Was hat der Liter Benzin für Paul durchschnittlich gekostet?
Paul Pankes Auto verbraucht etwa 4,7 Liter pro 100 Kilometer.
Wieviele km konnte Paul somit gefahren sein?

Schulnoten[Bearbeiten]

Paula Panke, die Tochter von Paul Panke, erhielt  folgende Zensuren:

Mathematik:	3, 4, 3, 2, 1, 1, 3, 2, 1
Physik:		3, 5, 4, 2, 3, 2, 4
Chemie:		2, 1, 2, 1, 2, 2, 4, 1
Biologie:	3, 4, 3, 2, 2, 4, 2, 3
Deutsch:	2, 1, 1, 1, 2, 1, 1,
Englisch:	2, 3, 2, 2, 2, 3, 1,
Geschichte:	3, 4, 4, 3, 3, 4, 2

Ermitteln Sie den Notendurchschnitt pro Unterrichtsfach.
Zur Abschlussprüfung werden mündliche und schriftliche Prüfungen durchgeführt.
Ab einem Notendurchschnitt von 2,5 oder besser wird nur mündlich geprüft.
Bei einem schlechteren Notendurchschnitt werden schriftliche Prüfungen fällig.
In welchen Fächern wird Paula Panke mündlich und in welchen Fächern schriftlich geprüft?

Leinwandpreise[Bearbeiten]

Preisermittlung

Leinwand auf Keilrahmen 35 x 35 cm 	39.00 EUR
Leinwand auf Keilrahmen 35 x 50 cm 	45.00 EUR
Leinwand auf Keilrahmen 40 x 40 cm 	45.00 EUR
Leinwand auf Keilrahmen 40 x 60 cm 	48.00 EUR
Leinwand auf Keilrahmen 45 x 60 cm 	49.00 EUR
Leinwand auf Keilrahmen 50 x 50 cm 	50.00 EUR
Leinwand auf Keilrahmen 50 x 70 cm 	55.00 EUR
Leinwand auf Keilrahmen 60 x 60 cm 	56.00 EUR
Leinwand auf Keilrahmen 60 x 80 cm 	65.00 EUR
Leinwand auf Keilrahmen 60 x 90 cm 	69.00 EUR
Leinwand auf Keilrahmen 70 x 70 cm 	75.00 EUR
Leinwand auf Keilrahmen 70 x 100 cm 	85.00 EUR
Leinwand auf Keilrahmen 30 x 90 cm 	50.00 EUR
Leinwand auf Keilrahmen 30 x 120 cm 	59.00 EUR
Leinwand auf Keilrahmen 35 x 100 cm 	58.00 EUR
Leinwand auf Keilrahmen 50 x 100 cm 	69.00 EUR

Versandkosten
unter 25 EUR: 5.75 EUR
ab 25 EUR: 3.75 EUR
ab 50 EUR: 0.00 EUR

Ein Anbieter von gerahmten Leinwänden hat die vorstehenden Preiskonditionen.
Ermitteln Sie die Endpreise für je ein Bild für jedes Bildformat unter Berücksichtigung der Versandkosten.
Ermitteln Sie die Fläche eines jeden Bildes in cm² und in m²
Ermitteln Sie den Bildpreis (ohne Versandkosten) pro cm² und pro m²

Anwendungsbeispiele[Bearbeiten]

Handelskalkulation[Bearbeiten]

Gesamtkalkulationstabelle zur Vorwärts-, Rückwärts- und Differenzkalkulation

Nachdem die Kalkulationsmethoden:

durchgearbeitet wurden, stellt sich nun die Frage nach dem tatsächlich erzielten Gewinn bei konkreten Konditionen.

Differenzkalkulation[Bearbeiten]

Bei gegebenen Lieferantenbeziehungen und innerbetrieblichen Konditionen werden hier die Selbstkosten gemäß der Vorwärtskalkulation errechnet. Anderseits wird aufgrund der eingeschränkten Akzeptanz eines Listenverkaufspreises durch die Kunden bei angestrebten Verkaufskonditionen der maximal erzielbare Barverkaufspreis gemäß der Rückwärtskalkulation errechnet.

Die Differenz aus diesen beiden Größen liefert den erzielbaren Gewinn. Im nebenstehenden Rechenbeispiel fällt dieser negativ aus - ein deutliches Zeichen dafür, dass entweder nachverhandelt werden muss, oder besser die Finger von diesem Geschäft gelassen werden sollten.


„Man kann diese Kalkulation auch als ‚vom Leben geprägte Kalkulation‘ betrachten.“

Zinsberechnungen[Bearbeiten]

Obwohl es in der Tabellenkalkulation ausreichend Tabellenfunktionen gibt, mit Hilfe derer man die Entwicklung von angelegten Geldbeträgen samt Zinsen zu fast beliebigen Zeiträumen errechnen lassen kann, bietet sich ein Kalkulationsprogramm doch an, die monatlichen oder jährlichen Zahlen im Zusammenhang mit Geldanlagen oder Darlehen mittels einfacher Zellbezüge berechnen zu lassen.

Wahrscheinlichkeiten[Bearbeiten]

Die unabhängige Auswahl eines Ereignisses aus einer Menge vorgegebener Möglichkeiten bietet sich an, um mit einem Kalkulationsprogramm Wahrscheinlichkeitstabellen aufzustellen.